XCode Cesuim version 1.6 build errors w/ Unity 2021.3.11

Recently added Cesium to a project using google’s ARCore. Added Cesium as a scoped registry. However, when I tried to build the scene w/ iOS these are the errors I got:

Any potential fixes?

You should be able to fix this by downgrading to v1.4.0 using the Unity Package Manager. I wrote an issue for us to fix the problem in a future version:

We tried reverting to 1.4 and ran into some other issues trying to build in xcode: Library not found for -lmeshoptimizer. Is this something we have to install separately?

1 Like

Downloaded meshoptimizer and added it to the project and we are able to build now–thanks!

That’s a little strange, because we didn’t start using meshopt until 1.5.0, so I’m not sure why you’re seeing that as a missing dependency in 1.4.0. Maybe the project files didn’t regenerate properly after the downgrade? In any case, glad to hear you got it working!

I’m actually getting the same “Library not found for -lmeshoptimizer” on Xcode with 1.4 and 1.5 versions

Very sorry for the inconvenience. Please try to import the package here: check if library.Cpu is null · CesiumGS/cesium-unity@a7ccfda · GitHub.

Best regards