Black lines on textures

Hi! Im uploading a photogrammetry scan from reality capture. The built in upload functionality crashes, so I exported fbx (export vertex normals: yes).

It uploads to Cesium Ion fine, but when I look at the model there are black stripes along all the edges, its probably something with the LOD generation I would think. Zoomed all the way in they dissappear.

I’ve also tried with larger texture gutter up to 16px, but I get the same artifacts.
Hope someone knows anything about this :slight_smile:

Screenshots (Last one is reference from RC):



Hello Steffen,

My apologies for the delay in getting back to you on this. I see your support message as well—thank you for the information there. You have an interesting project here, and I hope we can improve the artifact problem you are seeing.

One thing I noticed about your data is that it is very large—some number of times bigger than world scale. This user recently had a problem that seems somewhat similar, and they were able to work around it by changing the scale of their model. (Although, in their case, the scale had to be increased instead of decreased.)

Which option did you select for What kind of data is this? when uploading? I would recommend trying 3D Capture, if previously you selected a different option.

You could also try disabling Draco compression and/or reducing the maximumScreenSpaceError of the tileset (which, while probably not a real solution due to the performance hit it would cause, could help us diagnose the problem).

I am testing these options out on my end and will let you know if any of them is successful in improving the visual quality of the asset. Please let us know if you try any of them and have any findings to share.

Thank you,
Matt

Hi Matt! Thanks for your reply.

I’ve tried rescaling the model now, but with the same results. ID 673295
I have tried uploading with many different settings, I usually turn off Draco, but use WebP. I always upload as 3Dcapture. I have tried 3d model, but it breaks the model and loading as a complete gltf leads to performance issues.

My guess is that it has to do with the low polycount of the model and the high number of textures. We have done a lot of work repairing geo and textures, but it was done for a different goal and the polycount is under 200K… I guess that results in some problems when making the LODs, but there are no options to set when converting as far as I can see.

Let me know if you have any other ideas :slight_smile:

Hello Steffen,

I consulted with some colleagues on my end, and their guess was that either the texture coordinates aren’t correct or the texture atlas doesn’t have enough padding around the pixels. It sounds like you’ve already done some experimentation in those areas, though. It would be useful to see the UV map in Blender to see if the texture coordinates are sampling from black pixels. Is that possible?

Thanks,
Matt