Cesium for Unreal balck area

Hi, I don’t know how to solve this problem. When I load the earth using the cesium for unreal plug-in, if I run the simulation, it will appear a black area block. And when my camera moves forward, this black area block will also move forward. There will always be black on the left and right sides area, do I need to change any parameters?

Thank you for your reply.

I know a possible solution, just turn on use lod transition. But I encountered a new problem, does anyone know what happened?

Hi @docking9, welcome to the ocmmunity!

That looks like a strange rendering artifact. Can you give us more information so we can troubleshoot this issue? We’d like to know:

  • What versions of Unreal Engine and Cesium for Unreal are you using?
  • What Play Mode are you using? You can click the three dots to the right of the play button:
  • What data are you viewing? Is this Cesium World Terrain, or something else?
  • Please share a screenshot of your World Outliner so we can see what objects are in the level.

Once we have this information, we can help from there. Thanks!

@janine Thank you for your reply. I’d be more than happy to give you more information.

  1. The UE version I am currently using is UE 5.1.1, and the cesium for unreal plug-in is 1.29.0.

  2. This Play Mode uses Selected Viewport, I have not modified this setting;

  3. I now use the cesium for unreal plug-in and added the cesium world terrain + bing maps and cesium sky tools to the level. In addition, I added the airsim plug-in to UE. This plug-in is only used to control the movement of pawn during simulation. What I use now is the airsim plug-in to collect data pictures in UE.

When I am collecting, this “black stripe” problem occurs. I suspect this is caused by the sky light setting, because when I fix a sky light setting, the black stripes on the picture often appear in the same position. And when I change the sky settings, the “black stripes” also change position. But I don’t know of a suitable setting to prevent this “black streak” from appearing. Of course, this is just my guess. I have tried to turn the “Transmittance Minimum Angle” from -90 to 90, it didn’t work.

I had a similar issue early on but it was the sky turning black.
In my case I had two competing sunsky actors.
It looks like this screen shot above you also have multiple sun sky actors. I see the UE one is hidden in the editor but when you run is it competing with cesium sun sky?

@BDelacroix Thank you for your reply! Yes, I have two sun sky actors. But when I actually used it, I have
set the first one to “hide the actor in the game”. From the simulation effect, it seems that the first sky is not mapped. I don’t know if there will be any specific impact internally.

Hi @docking9,

Thanks for providing the information we requested! You mentioned that enabling the LOD transition setting makes it somewhat go away. I wonder if it’s related to a known bug in the default tileset material, where the dithering effect causes weird visual artifacts.

Could you try the workaround I outlined in this other forum thread, here? If that solves your problem, great! If not, we’ll keep trying other solutions.

I also noticed that you’re using an older version of Cesium for Unreal. We always recommend updating to the latest version of the plugin :smile: If you’re worried about things breaking, you can make a copy of the project before changing the version.

Either way, let us know how that material fix goes and we can keep troubleshooting from there.