Cesium server not properly working for a few days?

I am working on a real-time, high-precision GNSS deformation monitoring project which embeds Google Earth and Maps. Lately, I could replace Google with Cesium as many other people in this community. Everything was working fine but since yesterday, Cesium is not properly displayed. Is something going on with Cesium server?


The same here. Since yesterday the globe does not appear…

Bing key expired?

As I am a newbie in Cesium, I will need to learn a lot about this new application. If I am missing something, please correct me.

Currently, I use only ‘//assets.agi.com/stk-terrain/world’ in my project. For 2D maps, I still use Google rather than the Bing map on a separate embedded Web Broswer control. Should I get Being key anyway to run Cesium?


As Ashley pointed out, a Bing key was the source of my problem. I did not provide this key for my Cesium application over past one month. It seems I had only 30-day developer access. I created a new Bing key and input it into my Cesium application using Cesium.BingMapsApi.defaultKey=‘my bing key’. It’s working now. Hum… I still use Google Maps over years without a key.

Anyway, thanks for help.

My case seems to be different (I guess). I never used a Bing key since I started work with Cesium in April/2015. And also the Demos reached from index.html when I run ‘node server.js’ are not working or even HelloWord.html within Apps folder in Cesium installation…

Has someone any idea?

Generating your own Bing key in order to use Bing imagery is required, and has always been. Microsoft has recently disabled the key shipped as the default, so you must provide your own. See the documentation: http://cesiumjs.org/Cesium/Build/Documentation/BingMapsApi.html The default key is only suitable for development, and as you see from the current situation, may change over time due to factors outside our control.

I provided a key, now it works on Windows with node.js. But I am also running Apache in a Linux virtual machine and there it does not work.

I access this virtual machine from outside (host) using Firefox. This is strange.

Hi folks,

The Bing key included with Cesium is now working again.

However, Scott is right that you should use your own Bing key, especially when releasing a Cesium app.


Cached page! Then it didn’t load the updated html file with the Bing key…

Thank you all!

Thank you.

But I still think strange the fact I can run my key under windows but not under virtual machine. I will check this.