dae to 3D tiles working but without textures

1. A concise explanation of the problem you’re experiencing.

Tried to convert dae model to 3D tiles, and it’s working, except the textures are missing in resulting 3D tiles model.

Any hint how to add dae file and accompanied textures folder to Cesium Ion “My Assets” ?

Maybe textures should be placed in some spec folder or something ??

*Also tried KML format, *

and its working and even textures are present, but cannot alter locations data which is a must for me.

Maybe there is a way to alter KML locations data in “My Assets”?

2. A minimal code example. If you’ve found a bug, this helps us reproduce and repair it.

Attached testing dae model and accompanied texture folder, and examples of the same dae model converted as glft and 3D tiles format.

3. Context. Why do you need to do this? We might know a better way to accomplish your goal.

Converting SketchUp skp models to 3D tiles, to be added to the Cesium web map with custom terrain.

dae format is the most convenient since I need to manually adjust lat/lon/elev for each model.

Previously working with glft files but 3D tiles are much better option.

4. The Cesium version you’re using, your operating system and browser.

Cesium 1.52, Win 10 Pro 64bit, Edge 11/FF/Chrome/Android

3D_modeli.zip (3.64 MB)

Hey, thanks for letting us know! The missing textures might be an ion bug. Do you mind posting an issue on here:


And linking to this thread? That way the ion team can look into it and try it with your sample data.

For altering locations, I’m glad you brought that up. We were recently just debating whether this is a feature that ion should support for buildings, since buildings typically (at least in CityGML formats) tend to have the correct positions baked into it. Is getting the positions in SketchUp first and then exporting it possible in your workflow? Or is it a matter of positioning it on the globe/terrain?

Thanks Omar,
posted the same question on cesium-ion-community.

As for SketchUp, not sure atm.