How to use DEM tiff files in Cesium for Unreal?


Is there a tutorial about how load data from a local geoTIFF DEM file that I have locally into Cesium for Unreal ? I am confused about the workflow.

I am looking to be able to use custom DEM with more precision that the Cesium World Terrain.

I could import the DEM to Cesium Ion and use it into a story and now I would like to be able to have it in Unreal.

Hi @melindafe,

If you’ve successfully loaded the DEM in Cesium ion, you should be able to import it to Unreal using the ion assets panel. This section of the adding datasets tutorial goes over the process of adding an asset from that panel.

Let me know if you have any questions.


Thank you for your reply !

I followed the section you linked to step by step and still have the same problem.

So DEM is in my Cesium assets and I can see in preview that it is successfully integratated to the Cesium World Terrain.

Then in Unreal, I added the asset to my current level but it doesn’t display properly: all I see is a grey plane.

This doesn’t happen with Cesium World Terrain and Bing aerial.

Any idea why this is the case ?

Hey @melindafe,

That definitely doesn’t look correct, but just to double check, can you try applying an imagery overlay to your tileset in Unreal?

You can do this easily by adding Cesium World Terrain + Bing Aerial Imagery to your scene. In the Components section of the Details panel, you can find the “Bing Maps Aerial” component. Right click on that and copy it, then paste it in the components panel for your tileset.

I suspect that this will just add the imagery over your grey plane, but it might be helpful in visualizing what went wrong.

Also, could you open the Output Log? (Window>Developer Tools> Output Log). If there are any error messages there, please paste them here.



So I applied Bing Maps Aerial to my tileset. When hiding the Cesium World Terrain my tileset is still grey.

No error in the Output log.

Hi @melindafe,

It looks like Cesium for Unreal currently doesn’t support multiple terrain layers. Add support for multiple layers of quantized mesh · Issue #253 · CesiumGS/cesium-native · GitHub

I believe that as a workaround you can use Mean Sea Level instead of Cesium World Terrain as a base layer when uploading to ion.

You also may need to adjust the height - this tutorial may be helpful.

In Unreal, you can combine it visually with Cesium World Terrain by using a Cartographic Polygon to clip out the area where you would like your custom dataset.

Can you give that a try and let me know if it works?


Hello, :slight_smile:

After you last message I tried a few different things, with only one tile:

  • uploading 1 tile on Cesium World Terrain
  • uploading 1 tile on Mean Sea Level
  • reexporting the tile from QGIS before uploading it and try again with Cesium World Terrain and Mean Sea Level.

All of those result in the same grey flat area when importing it into Unreal… And still work fine in Cesium Asset preview and Cesium Stories.

Could it be a setting in Unreal ?

Hi @melindafe,

It looks like there might not be a good workaround for this right now, unfortunately. One thing you could potentially try is including low-res global terrain with your custom terrain, but I’m not sure if that would work either.

We’re hoping to add support for multiple terrain layers in Unreal soon. In the meantime, feel free to chime in on the issue I linked above if you have additional information about your use case.


Ok I see, I will have to find another way for now. Thank you for your help!