I Created a Cesium ion Scene Completely From Scratch and It Still Doesn't Cook

It’s an extremely simple scene with only the most fundamental basic features (georef,world terrain, sun sky) and it does not cook so I can not package the project.

The errors are below although I think the 404 is the culprit as I had not gotten the water collision error in my other scene.

This is rather frustrating as it makes it impossible to share the scene (at least with my knowledge). I simply want to package the scene and share it.

errs below:

UATHelper: Cooking (Windows): LogInit: Display: LoadErrors: Error: Collision Profile settings do not include an entry for the Water Body Collision profile, which is required for water collision to function. Add entry to DefaultEngine.ini?
UATHelper: Cooking (Windows): LogInit: Display: LogCesium: Error: [2024-02-13 23:11:37.711] [error] [ErrorList.h:72] Errors when loading tileset:
UATHelper: Cooking (Windows): - Received status code 404 for asset response https://api.cesium.com/v1/assets/96188/endpoint?access_token=eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJqdGkiOiJhMzU2YjZiOS0xN2FjLTQ3NmItYWNhOS05YWZlN2E0YzQ5ZjkiLCJpZCI6MTgxMDc4LCJpYXQiOjE3MDc4ODc0NjF9.F3SF-JoqExAOBKtFInsvipqlx_352nTOZAz426jmmgo

That 404 error is strange. Asset ID 96188 is Cesium OSM Buildings. If that’s giving you a 404, it suggests that either:

  1. You haven’t added it to your assets on the “My Assets” page in Cesium ion.
  2. You’re using an access token that doesn’t have access to Cesium OSM Buildings.

In any case, I wouldn’t expect that error to break packaging.

The Collision profile error might, on the other hand, but the solution to that one should be simple. See step 2.3:

I was able to bypass the first error by simply removing the OSM buildings.
Which is a little bit strange because I do have them in my assets.

However for the second error (Add entry to DefaultEngine.ini?), this is not a clickable link for me.
It is just plain text so I am unable to resolve this by clicking the text in my output log.

I followed link below and it cooks!
I think I can get to the OSM Buildings later but for now let me test some things and I will get back to the thread.

Generally I would rather use Google’s keys because Ion’s buildings are not as high-quality. But I get far more errors when I go that route.
I’ll be back haha.

ok so the above link worked along with removing OSM Buildings.

I’m not sure if the attached image is going to work but essentially I have the OSM Buildings in my assets but they don’t seem to actually work.

I have resorted to using “from url” directly with my 3dtiles api key which is the desired result but it would be nice to know in the future why that asset doesn’t work even though it’s in my library.

Are you sure you’re using the right key with Cesium OSM Buildings? Check if you have a key specified explicitly on the Cesium3DTileset. If not, then it will use the project default token. Click the Token button on the Cesium panel. Is it the key you expect?

By the way, is Cesium OSM Buildings showing up correctly in the Editor? Is it only at cook time that you get that error?

yes, it is only at cook time that I receive the error. it loads the buildings properly when I am in-editor but when I cook the project I get the error.

I was at least able to package the project using the google maps key, so my initial issue has been resolved however I am only curious as to why this hasn’t worked. it just seems weird because I can’t find anything wrong with my ion account or anything like that.