Loading 3D tiles not hosted on Cesium Ion


I’d like to import a dataset that is hosted on-premise, to the Unreal Engine plugin. What is the general workflow for this?

Hi Arkwiz, are you referring to loading 3D tiles from your local directory? Koz I did chance upon a tutorial on that, however did not manage to get it done successfully. Was about to post regarding this on the forum and chance upon your post.

Tell me if you’re able to get it done! Cheers!

Hi @Arkwiz,

As RidhwanAziz mentioned, this tutorial demonstrates how to load a 3D Tileset from a local directory (though I just realized it’s a little out of date.) If you’re trying to load a dataset that is hosted on premise, the process is pretty similar.

  1. Add a new blank 3D Tiles Tileset
  2. In the Details panel, change the Source from “From Cesium ion” to “From URL”.
  3. Paste the URL to your locally-hosted dataset in the URL field.
  4. If you need to add Raster Overlays to your tileset, add a Cesium Tile Map Service Raster Overlay component to your tileset, and paste the URL to that imagery overlay in the URL field on the component.

@RidhwanAziz, what was the issue preventing you from loading your tileset? Did it produce any error messages?


1 Like

Thank you for the input, I’ll try this out!

Hi @agallegos,

Thank you for your response. This is the error which was being prompted to me in the “Output Log” window when I entered the directory into the URL slot. Nothing appeared in the Viewport window.

It would be great if I could get your assistance to this issue. Thank you in advance!

Hi @RidhwanAziz ,

I think it is due to the space in your url. Try replacing any spaces with %20, it worked for me when I replicated the issue!

-Nithin Pranesh

1 Like

Hi @Nithin_Pranesh…you’re awesome! It worked. Thank you for the tips! Cheers mate!