Loading raster tileset from url


As far as I understand I can load a terrain tileset for determining height for the 3D tiles to the ion, then access this ion asset from Cesium 3D Tileset and add a raster imagery component on it for raster tiles.

So far everything with heights tileset works fine (I cant see changes inside Unreal) but I cannot access raster tileset (TMS or WMS).

How can I do this?

For example, I have this TMS link: https://s3.amazonaws.com/elevation-tiles-prod/terrarium/{z}/{y}/{x}.png - what should I do with CesiumTileMapServiceRasterOverlay component so the tileset could be accessed and loaded?

p.s. I also tried CesiumDebugColorizeTilesRasterOverlay - and it works fine (it appears in the world with my custom terrain tileset from ion)

Hi again @ureadulose,

Is this question related to (or even the same as) this post you’ve made here? If so, please let us know which thread better reflects your question, so that we can keep discussion to a single thread and avoid duplicating answers. Thank you!


I am sorry for an enormous delay in answer.

It’s similar one. I just thought that it would be better to separate it in two posts for local and for web access for tiles.

So, to make it clear, I am trying to implement both ways. I guess it would be better if we would discuss the remote variant.

I can’t figure out how to access tiles from public services. For example:

  1. I got an API from cloud.maptiler.com for a Raster Tiles (here is an example for this map).
    I added a blank Cesium3DTileset, put a terrain from a cesium Ion (asset Id: 2499908) - it successfully loaded, the terrain was blank. After that I added a CesiumTileMapServiceRasterOverlay component on it. I put the URL:


to the Cesium > ‘Url’ property inside CesiumTileMapServiceRasterOverlay component. But then i got this error:

LogCesium: Error: [2024-04-01 11:43:16.032] [error] [RasterOverlayCollection.cpp:127] Unable to parse Tile map service XML document.

  1. Also here (api3.geo.admin.ch) I found a free 3D Tiles api:


I tried to put it directly to the Cesium3DTileset > Url. It didn’t show any errors, but the terrain was not here. I also tried to add DebugColorizeTiles overlay but they didn’t appear in the world with this tileset also.

  1. Again from here (api3.geo.admin.ch) I also found wmts api, added CesiumWebMapTileServiceRasterOverlay, put


but again no errors were raised and the overlay still was not here.

A little remark: with terrain tileset from my Cesium Ion accound with Id 2499908, the debug overlay shows up correctly.

So, I would like to know what am I doing wrong.

And again, sorry for a such a big delay :frowning:

p.s. Oops, just noticed that answered you from another account :smiley: