Local tiles in Cesium for UE5


Good afternoon, Dear Cesium Developers!

When studying your product, I encountered difficulties, please help me!
I am new to the field of game engines and map data, I have not worked with UE before, my goal at the moment is to explore the possibilities of UE / Cesium. I apologize in advance if I don’t understand the obvious…

So, in summary:

  1. I want to use local tiles in Cesium for UE5. The area is huge, let’s say 250,000 square kilometers (by what method - through what tools to download large areas of elevation maps and satellite images for them is a separate big task for me, I have never worked with this either). At the moment I am working with small areas. Of key importance is the autonomy of the UE / Cesium / tile set, hence I cannot use the source of tiles from the Cesium ION servers.

  2. Installed UE version 5.0.3-20979098, Cesium 1.19.0, launched the project with Cesium examples - “CesiumForUnrealSamples” (see screenshot default_cesium_ion_UE_version.png). For the test, the TMS server of the third-party tool MapTiler Server with the Earth dataset (maptiler-satellite.mbtiles) was launched. Schematic metadata and path to tiles in local_TMS_server.png screenshot.

  1. To make sure the TMS server is working, I downloaded one of your products. In Sandcastle, by default, tiles are loaded from a relative path. If you remove the url, there is nothing on the globe. After using the url to my local tileset, I get the tiles loaded as expected (see screenshot of sandcastle_with_local_TMS.png). So my TMS service is running.

  1. Now to the main difficulty: in UE, in your test project, I create a “Blank 3D Tiles Tileset”, add the “CesiumTileMapServiceRasterOverlay” component and change the URL field from “Cesium ION” to my absolute path to the local TMS tiles. I specify the path to the tiles twice (see screenshots of UE_Cesium_with_local_TMS_1.png and UE_Cesium_with_local_TMS_2.png). There is an error message in the debug… I found a similar problem with tilemapresource.xml on the forum, but I think my tiles.json file is similar. There shouldn’t be any problems with the antivirus. I was expecting tiles to load like Sandcastle, but it doesn’t…

Please tell me what should I do next…

Thank you!
Sincerely, Vyacheslav Belkin

Did you ever get this working?
For some reason I don’t really think they want this to work or something.

I’ve been trying the same thing.

I want to stream a local tileset processed in metashape in Unreal Engine but it just does not load.

If I point to the example file from the tutorial it does work.

I have no idea how to fix this and every other thread I see relating this topic just seems to be ignored.
Might have something to do with the folder structure and or paths in the json tileset.

1 Like

Hello Team,

I have successfully loaded the 3D tile set JSON in Cesium for Unreal. Now, I am trying to load a model based on latitude and longitude coordinates. Can you please suggest a solution for this?

Thank you.

@Rajesh_Kalavakunta please tell us what your tileset looks like currently. For example, is it rendered correctly, but it’s at the center of the Earth? Please post to a new thread, as this one appears unrelated to your question.

Dear @Kevin_Ring,
I have created a new thread. Load 3D tile set based on latitude and longitude coordinates

Thank you