model conversion transparency problem

When converting a COLLADA model to glTF/glb using the online converter I have problems with the transparency of polygons when viewed from the backside. Polygons that appear (correctly) transparent form the backside in the COLLADA model become opaque once converted.

Attached are simple example files for an original COLLADA model and the converted model.

Thanks, Matt.

rmax_rotor.glb (305 KB)

rmax_rotor.dae (9.48 KB)

The model seems to work ok for me, I’ve attached two screenshots. Can you post a screenshot too?



I’ve attached screenshots from Chrome and Firefox.

Could it be my particular machine/graphics card? Mac OS X 10.8.5, NVIDIA GeForce GTX 675MX 1024 MB , Chrome v 49.0.2623.112, Firefox v47.0.1

Thanks, Matt.

Ah, is the issue that the transparent section are tinted black? I think that’s happening because by default the COLLADA2GLTF converter will not hide back faces for transparent sections, so both sides of the disk are visible. And since the back side is dark due to the normals facing away from the camera, the whole disk appears dark. The first thing I would try is create a one-sided disk, similar to the CesiumAir model. Another thing worth trying is setting the gltf state to cull back faces - in the glTF in the “states” section add 2884 which signifies CULL_FACE. The first approach is probably easiest and won’t require manual tweaking.

Yes, that is the problem.

I need to be able to see the rotor from both sides. If I add 2884 to the gltf states section the view from the top is now correct but the underside appears as shown (see attached).

I use Sketchup to create the COLLADA model. When you say create a one-sided disk I’m not sure I understand what you mean.

What I mean by one-sided is Sketchup seems to export the transparent area with a two quads, one facing up, and the other facing down. If you load the model in a different modelling engine you may be able to remove one of the sides, but unlikely in Sketchup itself.

I’ll have to do some more investigation about the back side being opaque, I can’t reproduce it though.