Model looks way worse in Cesium Ion than in Dronedeploy

Hi there

I’m a beginner in the world of 3d city models shot with a drone. I import my footage into Dronedeploy (an app that does run on Cesium) which gives pretty decent results. I then export the result as a 3D model (.obj) and import that one into Cesium Ion. So far I’ve tried the import twice, once with Draco Compression and once without. Even without compression the quality of the model in Cesium Ion is so bad that I can’t use it. Do you have an idea how I can solve this?

Edit: It can’t be the export file from dronedeploy because that one looks great when imported in MeshLab.

Closeup in Dronedeploy:

And the same location after importing the model into Cesium Ion:

Overview in Dronedeploy:

Same location in Cesium Ion:


There are several optimization settings set by the engine for performance reasons. You can tweak them to make your model display with higher quality. If you go to “My Assets” page in Cesium ion and click on “3D Tiles Inspector”, you will be able to change the maximum screen space error. The higher this value is, the faster your tiles will load but the less detailed it will be.
Please follow up if you don’t see satisfactory improvements.

Hi dzung,

thanks for the reply, that sounds easy! Unfortunately I do only have “Adjust Tileset Location”. Maybe I can find the Inspector somewhere else?

Best, Michael

Can you please send me the asset ID of your asset to support@cesium? I will look into it on my end and see why you are not able to access the mentioned setting.

Sure, I’ve sent it using the contact form for support, hope that’s ok. You can also find it in the screenshot below the picture of the model.

Best, Michael

Edit: Should I delete the screenshot to protect the asset ID?

Oh yes, I didn’t see it there.

One would need both your asset id and your token to access the asset. :grinning:

I double checked and found that the maximum screen space error in the inspector is not permanently saved. For importing models into Cesium Stories, unfortunately there is not currently a setting to change that. However, the feature is in our roadmap for the near future.

Please see my latest email from support@cesium for suggestions.