Mesh uploading as a 3D Capture leads to really bad visual issues

Hello everyone!

Here’s my trouble.

I’m working on a city map with LOTS of custom 3d building models on it. So, while trying to keep my data as “3D Model” I faced heavy problems with RAM run out, low FPS and so on. Then I managed to upload my assets as “3D Capture” and really loved how nice and swift all the things work with that view distance optimization.

But when I’m trying to upload some of the models with “3D Capture” option (Draco compression on/off - doesn’t matter) something goes wrong with the tiler I guess. Some parts of the models starts disappearing on certain view distance: not too far or close, something inbetween 90-135 meters away from model. Here it is on applied screenshots, ID 1296253.

This is definitely not dependent on whether the model is textured or not, because the problem appears on non-textured models as well (the one on the left, ID 1296252).
What is even weirder, the problem often does NOT occur on models that are very similar in geometry with corrupted ones (long building on the right, ID 1296254).
I tried to fix my problematic buildings geometry with lots of ways (I’m working in Blender): recalculating, tris to quads, deleting interior faces, rebuilding problematic areas - nothing helps. I tried using different exporters and file formats: .obj, .dae, .fbx - nothing as well. Tried different mesh grouping inside the model: keeping all meshes as one piece, as separate pieces and individual textures, as one piece and another separate one for problematic area - nothing, nothing, nothing.

So. are there any ways to solve such an issue? Or at least any methods on how to keep tons of complicated geometry without serious performance drops?

I also provide:

Thanks a lot!

Today I noticed that the problem described is somehow related to non-manifold (interior) faces, which is quite a problem, since I don’t have enough time to redo the geometry. At the same time those models with non-manifold geometry are displayed correctly, when uploaded as “3D Model”, which I think is related to the fact that “3D Model” asset type is not being compressed while shown in Cesium.

It also seems that culling surfaces only appear after the asset is fully loaded. Whenever you quickly scroll the camera at ~110m +/- 20 meters above compressed “loading” models - everything remains just fine until the models load completely.

So, the question is still relevant for me: are there any methods to fix tiling issues caused by inaccurate geometry when keeping it as “3D Capture”?

By the way, would using glTF assets be an appropriate solution in my case?

I have 319 building models, which I can upload as .fbx or convert to glTF before uploading. Is glTF tiler really so light-weighted and easy-to-load in WEB? As for regular .fbx’s used with “3D Model - tile as 3D tiles”, it was a nightmare trying to run all the scene at once.

And one more about glTFs: will I be able to use them in Stories and manually position them on map, if commercial account status is active?


I can reproduce the error on my computer, but not sure whats causing them. Its quite unusual for the triangles to be culled like that.

Let me see if our engineering team has any thoughts about it.

Since these are designed in Blender, the “3D Model” asset type should be better for this. Are you optimizing the textures in the Blender model so that they are repeated and not full sized?

If you are having issues with memory even when using 3D Tiles, I would not recommend using glTF as it would not have any LODs.

Hello! Thanks for the answers!

It would be great if engineers could find something.

Since these are designed in Blender, the “3D Model” asset type should be better for this. Are you optimizing the textures in the Blender model so that they are repeated and not full sized?

Please tell a bit more about what you mean by “repeated and not full sized”. I’m able to UV and bake textures by any ways available, just don’t get what you are suggesting here :slight_smile:

What is really bad, is that I don’t have enough time to redo the geometry, which is awful, I suppose. Models are very innacurate, made via SketchUP an then imported into Blender. Most of buildings “weight” 1,5MB at .fbx export, sometimes even more. Could this be a reason why RAM drops take place, when 300+ such models trying to load, since we are talking about “3D Model” asset type?