Moiré pattern when turning on soft shadows

The official example: Cesium Sandcastle

Soft Shadows: false

Soft Shadows: true

How to remove the Moiré pattern?


Welcome to the community! Thank you for pointing this out. I have played around with this demo before but I have never noticed this behavior. I am not sure if this is a bug or a feature/artifact. Any suggestions or ideas from the rest of the community? In the meantime, you could consider setting Soft Shadows: false and modifying your light source object (DirectionalLight, Light, or SunLight) to generate a softer shadow.