No collisions on the PointClouds tileset in a packaged build

Hello, Cesium team.

Trying to make a successful Trace Hit on the PointClouds tileset. By default any trace passes through the object, but when I turn CreateNavCollision and CreatePhysicsPrimitive (although I know it shouldnt work for point clouds) on, the trace succeeds and everything works properly.

The problem starts in the packaged build - trace passes through the pointcloud tileset.

Unreal version: UE4.27 / UE5.1
Cesium for Unreal version: 1.24.0

What I tried:

  • Tried it again on UE4.27 / UE5.1
  • Turned off AutoDestroyWhenNoNavigation in Project Settings
  • Set RuntimeGeneration to Dynamic
  • Forced Rebuild of NavMesh

Any ideas?

Best regards,

Hi @Cheshenok,

We currently do not support physics meshes on point clouds because the physics engines can’t bake meshes from them. Can you manually place some colliders instead?

Of course, I can add some colliders, but since the data is always dynamic (different assets from Cesium Ion) this does not solve the problem, since I need something similar to Complex Collision.

The question remains open regarding Nav Mesh: why does CreateNavCollision work on Cesium Asset in the editor but not in the packaged build?