Problem with rendering 3dtiles

Hi everybody,

I would like to get a part of a city model from .dwg into cesium. I have converted the model into 3dtiles but after uploading it into cesium, a problem with rendering all surfaces has come up (check attached image). As I rotate around the model only some of the surfaces are visible, while they change while moving around. This means that they are actually there but not always visible?! Checking back the initial model, it seems fine (2nd attached image). I followed the same process with a different model and it worked perfectly. I am using Cesium 1.49 in windows10. The convertion was done with fme from .3ds to citygml. Any ideas what is the cause of this issue? I would appreciate any kind of feedback!


had a similar problem and some vertices’ order were wrong.

Had also to invert normals which in some cases where pointing inside.

Fixed it using an ‘FME’s Orientor’ transformer to re-orient vertices order and the normals properly.

Please take a look at

If you find a better and, especially, free and/or open source solution, please, let me know, thanks.


Great! Thank you very much! It worked!
If I find another solution, I will get back to you!

You’re welcome.
Glad it helped :slight_smile: