Strange orb-like object in Cesium JS


I have tried to view 3D Tiles in Cesium 1.94 on a certain location (lat/long: 51.917443, 4.479180).
But when I do that, the object does not appear on that location, but a bit above (see first picture below).
First, I thought it had to do with a different coordinate system.
But when I reproject it, it still does not work.
Reprojecting did work for other similar datasets when I wanted to view them as 3D Tiles.

So, I though it might have to do with an orb-like object that is located there (see picture below)

According to Google Maps, it should not be there in real life.

Does anyone know what it is and how I can get rid of it?

Cesium defaults to using Bing Imagery. If we look at the same spot in Bing Maps, we see the same weird blob:

This leads me to believe that Cesium is just displaying what we are getting from Bing.

If real life imagery isn’t important for your application, you can use any other imagery provider if you’d like. For example, OpenStreeMap: Cesium Sandcastle

For the misplaced tileset, what is the source data? Have you tried tiling it in Cesium Ion?

Sincerely, Erixen

Hi Erixen,

Well, I actually do need to use the real life imagery (for screenshots), but I have made the screenshots from a different angle, so that the orb is not really visible.

I fixed the misplaced tileset. It had to with reprojecting the coordinate reference system after all. So that is solved.