Terrain texture only streams in at a very low resolution

This is what I am seeing after upgrading to v1.29.0 of cesium-unreal.

Some details:

  • using UE5.2.1
  • cesium-unreal v1.29.0 (having the issues)
  • cesium-unreal v1.27.0 worked perfectly (not sure about v1.28.0)
  • using a custom 3d tiles server
    (this server still works correctly when viewed with cesiumJS and also worked correctly with earlier versions of unreal-cesium)
  • I can confirm that the issue is not related to UE5.2.1 upgrade but definitely related to cesium-unreal v1.29.0, since it worked correctly with UE5.2.1 and cesium-unreal v1.27.0

Is there a known bug/issue that can cause this?
Hoping for a workaround or fix soon, please.

That’s very strange. Can you try uninstalling and reinstalling Cesium for Unreal to ensure you have a clean copy?

You can also get past releases from this page to confirm that it did work in past versions:

Unzip them to your C:\Program Files\Epic Games\UE_5.2\Engine\Plugins\Marketplace directory. Be sure to uninstall the existing version using the Epic Launcher first.

This was actually picked up in testing on another machine, so not specific to my setup. I have confirmed that it only occurs with the latest version of cesium-unreal, but I will double check with v1.28 and v1.27 again.

Can you also check if it happens in the Cesium for Unreal Samples project anywhere? If not, we’ll need your help to reproduce the problem ourselves before we can debug it.

I have confirmed that cesium-unreal v1.29.0 works correctly with ion assets as well as with google maps.

Our server also works correctly with CesiumJS (sandcastle), so not clear yet where the issue could be.

Confirmed that v1.28 of cesium-unreal works for me. Is there anything in the latest updates on cesium-native that could cause the missing detail when I try v1.29?

And interestingly, with v1.28 it got the higher detail even just from the internal sqlite cache. So, with v1.29 it seemed to have streamed all the data, it just did not display it correctly.

I don’t know what might cause that. As I mentioned before, can you pleaes try the Cesium for Unreal Samples project and see if it happens there as well?

I have not had a chance to test with the samples project and I will give you some feedback hopefully soon.

I did however quickly check with the new release (v1.30) and it did not fix the issue we are seeing.