Tms service failed to load

Hello! There are three problems:
(1) Is there a specific local loading grid image service case.
(2) I use http://localhost:9003/image/wmts/hLZcYhvm/ {z} /{x}/{y} and http://localhost:9003/image/tms/hLZcYhvm/tilemapresource.xml
Both failed to load
The following is a screenshot of the failure

(3) Can Google Maps service be loaded?

  1. Sorry, I don’t know what you mean by “local loading grid image”.
  2. Your second URL, ending in tilemapresource.xml, looks like the correct one. What content is served from that URL? The first step is diagnosing any problem is to look at the Console tab and see if there are any relevant messages.
  3. I believe this is against Google’s terms of use, so we have never explored the technical feasibility.

Hello! I also have a similar problem.
When I import the local TMS, nothing happens, I would like to ask if it is the URL format I entered.Below is a screenshot of my issue.

Please make sure you’re running Cesium for Unity v0.3.1. The previous version, v0.3.0, had a bug that prevented the use of local data.

Hi,Kevin_Ring. I do use Cesium for Unity v0.3.1 and I have no problem importing 3D tiles. When importing TMS, nothing happens, and no error is reported at the console.

Can you share the content of your tilemapresource.xml file? It might provide a hint. One small thing I see in your screenshot is that you’ve configured the maximum level to be 20, but you only have through level 6 in your directory screenshot.

Hello, is a screenshot of my tilemapresource.xml

Looks like you have the same problem as the poster in this thread:

Your tilesets have a blank href property, so Cesium doesn’t know where to find the tiles. It’s fine for that attribute to be missing entirely (in which case Cesium will use the order field as the relative URL), but if it’s present it has to be valid (not blank).

Hello, Kevin_Ring. Since I haven’t used TMS slices before, I would like to ask how this TileMapResource .xml should be changed

Delete the href attributes from the <TileSet> elements.

Hello,Kevin_Ring. after deleting the href attribute, I still cannot add tms local image successfully. Could you please send me a tutorial on adding tms image? I also hope to see the configuration of Tilemapresource-xml, thank you very much

There is no such tutorial. Generally you just put in the URL. But if your service doesn’t match the spec (or Cesium for Unity’s expectation of the spec), then it won’t work.

If you tell me what is happening now, maybe I can help.

Hello,Kevin_Ring.Below are screenshots of the various screens of my project, I don’t know what happened, and there is still no corresponding effect on the display interface。

Ok the problem now is that your tilemapresource.xml has incorrect casing in the element names. XML is case sensitive. For example, <tileset> should be <TileSet>. See the spec:

It’s strange that you’re not seeing any errors in the console about this. I wrote an issue for us to investigate that:

I tried editing a working tilemapresource.xml to have lowercase names like yours, and I do get an error in the console saying:

Unable to parse Tile map service XML document.

But I don’t see that in your screenshots. Did you clear the console before you took the screenshot perhaps?

Hello, I did not empty the console, that screenshot is the result of my operation, and at the same time I modified the .xml to . Any reaction to the XML business, whether it is a problem with my TMS resources

Adding a Cesium Tile Map Service Raster Overlay directly to the Cesium World Terrain model can be displayed, but after overlaying the tms service, the superimposed Bing maps Aerial tiles may not be displayed sometimes

Hello, Kevin_Ring thank you very much for your help, I started using TMS slices, created a new 3D object, the CESIUM tile map service raster overlay used on the 3D object, nothing happened, added on the CESIUM World Terrain, and finally can use TMS slices

Oh right, that makes sense. I hadn’t noticed in your screenshot that you only have the TMS overlay component. A raster overlay is just that: an overlay. Without something (a Cesium3DTileset) to overlay it on, it does nothing.