Unreal Cesium Load Error, Refreshing/Respawning is ineffective

I’m using cesium to stream google’s 3d map tiles for a linux build and am getting a weird bug where the tiles seem to not load. However, when getting the “load progress” variable, it shows a regular increase to 100% loaded, AND the On Tileset Loaded event is also firing. When this happens, I have tried to call the “refresh tileset” function as well as completely destroying the tileset actor and spawning in a new one, both to no avail with still not a single tile loading and the load progress variable still incrementing normally. The strangest thing is when the tileset is refreshed and “loading”, it still lags the build even though nothing visible is happening. This bug only appears when the tileset is in a complex, performance heavy level, but is sporadic in its frequency of appearance. Any insight on this issue would be greatly appreciated!

Just a shot in the dark (I don’t have a Linux build) – in your Viewport options, do you have the “Realtime” setting enabled? Tiles will not appear if this is disabled.

Hey Janine, I do have the realtime setting enabled and I also don’t think that that would effect the tile loading in a runtime build. I do seem to have discovered that this bug only happens on a client/server configuration, not on standalone, so perhaps this could be related to bandwidth?

Are there any messages in the log, by any chance? If no tiles are appearing at all, I wonder if you could be hitting your quota with the Google tile API?

Hey Kevin, I think it’s definitely not from the api quota, and I couldn’t find any logging from cesium in the logs. I wonder if this is a port issue as I’m running these builds on a server pixel streaming setup. Is there anyway I can debug or change the port cesium uses?

A port issue? I wouldn’t expect so. It just uses the normal HTTPS port (443). There’s no way to change that short of convincing Google to run their tile server on a different port.

Hmmm, ok. Any other ideas on what could possibly be causing this?

Hmm not really. Perhaps you could share some screenshots or videos of the problem? Ideally, if you can give us instructions for reproducing the problem ourselves, then we can debug it.