Unreal render flythrough with Cesium crashes

I have just started using Cesium for Unreal plugin. I have followed all tutorials to set up a level all went well. I am able to play with it and its quite amazing. Having said that I am trying to render a test flythrough nothing fancy basic stuff. I have created a camera path got it to work in preview so far so good. In the final step when I try to render the sequence I run into trouble. First 900 frames all works well the rendering happens with the speed of lihght but after 900th frame Unreal starts to slow down and eventually crashes. It is almost as if the Cesium cant keep up with refreshing the environment aroun. I have tried numerous ways to fix it most of the fixes suggested in various posts unfortunatley the problem persists. I have two Nvidia RTX 4090 24GB cards beast of a CPU. When I monitor the usage the GPU crunches well for the first 900 frames at 60% but after 900th frame the3D graph drops to 0 and the whole thing crashes. I am nwew to this so any help will be gratly appreciated. Thank you in advance. Klaude.

Hi @44Klaude, welcome to the community!

That sounds like a bad bug; I’m sorry that you’re experiencing it! Can you share more information with us so we can further troubleshoot it? In particular:

  • What versions of Unreal Engine and the Cesium for Unreal plugin are you using?
  • What datasets are you trying to render? It would help to have a screenshot of your World Outliner, so we can see exactly what’s in your level.
  • Is your Level Sequence actually inside your level? This is necessary for the sequencer to work.
  • Can you share a screenshot of your rendering settings with us? (like # of warmup frames)

Thank you!

Hi @janine.
Attached is my screen shot.

Trust this helps.
Thank you.