Zoom out/in issue in the mobile app


I’m trying to create a functionality where user is able to Zoom In/Zoom Out the whole Earth like Google Earth using multi touch screen in the mobile app, but it doesn’t work properly. The center of the Earth is always linked to the initial place where user is started, in my case it is an island (see image attached

However, I expected that when you are zoom out to the whole Earth the center of view should be in the center of Earth. Do you know where I can find the information how to fix this problem?

Thank you,

Hi @Andrey.K,

This is due to the nature of CesiumGeoreference. The CesiumGeoreference specifies a location on the globe to be centered at the origin of the Unreal level. If you’d like, you can set this to the center of the Earth by setting its Earth-Centered, Earth-Fixed coordinates to (0, 0, 0). However, be mindful that any Unreal Actors that don’t have a CesiumGlobeAnchor component may appear to “move”, because they will be repositioned relative to this new origin at the center of the Earth.

1 Like

To add to what Janine said, it may be helpful to switch the CesiumGeoreference to “True Origin” mode. This will put the origin at the center of the Earth.

1 Like

Thank you, Kevin! I will try this one. Janine’s comment also was helpful, but switching to True Origin mode might be helpful as well in order to solve falling underground issue.

Unfortunately probably not. In Unreal, gravity always pulls in the -Z direction. In “True Origin” mode, that will be toward the South Pole, not toward the center of the Earth. The only workarounds I’m aware of are to either use sub-levels (in which each sub-level will have a correct local gravity direction, but only one sub-level can be active at a time), or turn off gravity and manually create a force toward the center of the Earth instead. I’ve never actually tried the latter, but it should work in theory.