Cesium on premise

I encountered some problems below using cesium 3d tiling pipeline (on-premise).

I tried to tile about 30,000 city gml files into the 3d Tiles with this command line
"./3d-buildings-tiler -I CityGML --input F:/fmemodel/1 -o f:/fmemodel/3dtilesTMS"
and I received a message like this
“Details: spawn ENAMETOOLONG”

I tried this command line below,

"./3d-building-tiler-i CityGML–input-list F:\fmurdel\LOD25WS-files.txt-o f:/fmoueldel/3 dtilesTMS.3 diles-database F:\fmurdel\LOD25WS-files3.db–progress-percent true -q TMSWGS 84 --content-level 18"

and I got the message ‘The “path” argument must be of type string. Received undefined’.

Is there anything I can do to deal with.


Thank you for reporting this problem. This appears to be a known issue that some users have experienced when sending a large number of CityGML files into the tiler at once. As a test of file validity, have you tried tiling a subset of the 30,000 files? Approximately how large is each file, and what software was used to generate it?

If you send us the data, we can take a look internally.