Cesium World Terrain disappear when rendering video

Hello everyone,

I’m using Cesium ion to bring a 3D tileset to Unreal Engine 5.1.1. But I’m having problems with Cesium World Terrain. As you can see in the image attached I can see both, my 3D tileset and the Cesium World Terrain, but when I try to render the video, it shows only the 3D tileset. Is there a way to include the World Terrain ?
I’m new to Unreal Engine, so any help will be much appreciated. Thank you

I’m quite sure what would cause that. Two possibilities I can think of:

  1. Some setting on the Cesium World Terrain Actor. Try removing it and re-adding it with the Quick Add panel.
  2. Something with the camera. Perhaps Cesium for Unreal is not using the camera used for video rendering in its tile selection. Your other tileset shows up just because the relevants parts of it happen to be selected even by the “wrong” camera.

Cesium for Unreal’s code to get the relevant cameras in the scene can be found here:

Basically, cameras that are associated with a player controller will be picked up automatically. As will any ASceneCapture2D actors in the scene. I think the GetEditorCameras bit won’t apply during a sequencer video render. So, perhaps make sure that your render is driven by the player controller’s camera, rather than some other camera in the scene.

Hi Kevin, thank you very much for your quick response. Your second option was the solution for my problem, once again thank you for your help.

Best regards,