Error in upload cesium ion in blender

Hello, there is a problem while using blender(3.6.4) to upload 3d model to ion:

it can’t launch webbrower when I click the upload to cesium ion.

Is there any solution about that?

Hi, sorry you are having trouble with this plugin.

If you can provide some more information that will help us troubleshoot the issue:

  • What version of Python are you using?
  • Was this previously working or did it never work at all for you? If it stopped working, do you know what changed (new version of blender, new version of python, etc)?

You can try exporting the file and then uploading it to the Cesium ion website manually to work around the plugin issue.

@mdc9001 … how can we export a .blend file and upload it manually to Cesium Ion?

Hi, thank you to reply.
I did not install python in the computer. I also try to upload(obj/mtl) to the Cesium ion website manually, it looked stucked , but I will wait until it turns out some result information.

After several hours of tile processing, it seemed to throw an error:
please email support@cesium.com with the asset ID: 2308072.

we use blender to export this data, it is obj+mtl, texture images are in the file.

Hi, I have created an issue for the team to investigate further. We will update you once we have more information.

  • What version of Blender are you using?
  • Can you tell us what type of data this asset contains?

Hello, thank you mdc9001, the version of blender is 3.6, the data assets is about a 3dmodel of a city, and it contains a mtl file, a obj file, and several texture file in jpg/png.

Thank you for that information. I have update the issue with our team.

Since you are working with a 3d model of the city, have you tried using the 3D Capture option? That option may work better for city models. Here is more information about the differences between the 3D Model and 3D Capture options.

Thank you for the advice about trying using the 3D Capture option, mdc9001, I will try it.

Hello, mdc9001, After hours of processing using 3D Capture option, it finally throw an error: please email support@cesium.com with the asset ID: 2317908.
The data I use is fbx export from blender, it is so strange, or is there something need to be written in code to manipulate the process pipeline by myself?

Hi, we apologize that this asset is not tiling. I have opened an issue for our team to investigate this further. We will update you on any progress.

All right, thank you mdc9001.

I have a similar error in using Cesium ion addon with Blender.
According to Cesium Learn instructions at Blender – Cesium, I follow every step but I failed to [Upload to Cesium ion]. That means the 3D model is not uploaded to Cesium ion as My Assets.

I use Blender version 3.5 with <io-cesium-ion-v1.0.0> addon installed. FYI, Python 3.12 is installed on the same machine. How can I resolve it?

The [Blender Info Log] reads as follows;
Python: Traceback (most recent call last):
File “C:\Users\kschoi\AppData\Roaming\Blender Foundation\Blender\3.5\scripts\addons\io-cesium-ion\panels\export.py”, line 85, in draw
self.required_prop(csm_export, “source_type”)
File “C:\Users\kschoi\AppData\Roaming\Blender Foundation\Blender\3.5\scripts\addons\io-cesium-ion\panels\export.py”, line 53, in required_prop
name = property_group.annotations[property_id][1][“name”]
TypeError: ‘_PropertyDeferred’ object is not subscriptable