Have solved the problem about using UE's SQL plugins? What's the reason?

Have solved the problem about using UE’s SQL plugins? What’s the reason?
About database in UE, i still have many confuse.


The SQL issue should be resolved in the coming release. You can track information about the issue here - In Shipping builds, Cesium for Unreal ends up using UE's SQLite, causing crashes · Issue #245 · CesiumGS/cesium-unreal · GitHub

If you have any other questions, let me know, and I’ll see if I or another member of the team can answer!

@agallegos OK. Thank you.
I make a test, when i make plugins (SQLite[SQLite Database];SQLite Support[SQLite Database Support]) which built-in UnrealEngine enabled, my project can packaged completed.
And, when i follow this paper that teach how to use sqlite, my project can packaged completed also.
Howerver, once i make built-in plugins enabled together with use sqlite, my project packaged failed, and the errors show:

Where is my fault?

Zip file below is my processed sqlite can use directly.
Sqlite.zip (2.2 MB)

Hi @yuan1405

It seems like the linker detects two sqlite3 definitions at the same time: Unreal Sqlite and an another sqlite you link against the project. So it maybe the reason it gives the error: LNK2005 symbol already defined in object. Cesium Native avoids this problem by changing all the name of sqlite3 symbols to something else to avoid violating C++ One Definition Rule (ODR). I think it’s better to use the sqlite3 that comes with Unreal Engine, instead of linking against another one. Maybe Unreal UDN can help with how to use their embedded sqlite plugin

@BaoTran Thank you.