Intersected Tilesets incorrect behavior with Cartographic Polygon


Currently we have some large scale photogrammetry tilesets that are in a UE4 scene. We are using the Cartographic Polygon to clip sections out of the Tilesets to place other content.

We are encountering an issue however, where the Photogrammerty tilesets when at LOD 0 are incorrectly culling the tiles that intersect with the edge of a Cartographic Polygon.

We are not sure whether there is a possible tileset processing issue or it is a bug. Any help in identifying or things to try would be appreciated.

In the two video there is a 75mm capture with larger tiled sections and a 20mm capture with smaller tiles, in both cases the issue can be seen.


Hi @V2i,

Thanks for reporting this. Out of curiosity, does unchecking the “Exclude tiles inside” parameter on the Polygon Raster Overlay help with this issue?


Hi @agallegos ,

We have tried unchecking the “Exclude Tiles Inside” parameter as a first step however it did not change the issue. We also though it could perhaps have to do with the tangents of the Tileset so we tried a few combinations of “Always Include Tangent”, “Generate Smooth Normals”, disabled and enable the different culling options but so far the outcome has always been the same.

Hi @V2i,
Thanks for checking - it’s good to know that those options didn’t have an effect. I’ve escalated this to the engineers, I hope to have an update soon.


Also, just to clarify, these are all your own tilesets, correct? Or is it also happening with Cesium World Terrain?

Unfortunately it only is happening with our datasets.

We tested the Ion Melbourne Photogrammetry, OSM Buildings and the World Terrain all of which behave correctly. So we are thinking maybe it is more to do with the dataset rather than the plugin side.

If it is easier we can provide a link to a small dataset that has the issue for testing on your end?

Hi @V2i,

One more thing you can try is checking in wireframe mode by changing the View Mode in the viewport to Brush Wireframe. If you can see the mesh still there on one of the missing tiles, it could be a problem with the overlay. If it’s not there, then the incorrect behavior could be caused by the bounding volumes on your tileset.

If you could provide a dataset, that would be helpful. You can send it to me in a DM if you prefer.


Created a new issue for this here - Incorrect tile culling behavior with Cartographic Polygon in Unreal 4.26 · Issue #808 · CesiumGS/cesium-unreal · GitHub

If anyone who finds this post is experiencing the same issue, please add any information you can.