Mount Fuji limitation? @CESIUM TEAMS

I’m using Meta Quest 3. When I’m browsing Mount Fuji, how can I zoom in for a close-up view? The tiles disappear, and I can only see the terrain.there are no problems with the United States. What could be causing this limitation?

The appearance of videos on Quest 3 is abnormal, but the desktop version is normal!!!

May I ask what the reason is for this, and how should I solve it? Thank you@CESIUM TEAMS

Hi @compaqnx9000,

That does look like abnormal behavior. Can you provide us with more detail so we can troubleshoot your issue? In particular,

  • What versions of Unreal Engine and Cesium for Unreal are you using?
  • What terrain dataset are you using? Is this Cesium World Terrain? Google Photorealistic 3D Tiles?
  • I wonder if the device memory limitations are causing this error. Does reducing the Maximum Cached Bytes on your tileset make a difference?

Thank you in advance!

hello @janine
I am using:

  • Unreal Engine Version: 5.3.2-29314046+++UE5+Release-5.3
  • Platform: Windows 11 (23H2) [10.0.22631.3296] (x86_64)
  • Cesium for Unreal Version: 2.4.0
  • Device: Meta Quest3 128G
  • Mount Fuji location: 35.407357, 138.814268, 2083.092607

The terrain I’m using is CesiumIonRasterOverlay. At one point, I suspected that CesiumIonRasterOverlay might have restrictions on the map tile display level for Bing Maps because I vaguely remember reading somewhere that, apart from the North American region, the map tile levels were reduced by m-n levels. However, I couldn’t recall the source, so I’m seeking confirmation here if such a limitation exists. Consequently, I removed CesiumIonRasterOverlay and replaced it with CesiumBingMapsRasterOverlay, using my own Bing Maps Key, but the result remained the same as shown in the video. Additionally, I don’t think it’s a device memory issue because Shanghai, which is not far west of Mount Fuji, appears normal, even when the camera zooms in closely. However, I observed that as I move further west from Shanghai, for instance, to Beijing, it’s the same as Mount Fuji, where there’s nothing visible when zoomed in

Oh, I almost forgot to mention, the value of Maximum Cached Bytes was set to its default value when I recorded the video

Looking forward to your reply.:)

Hi @compaqnx9000, thank you for the detailed response!

I don’t believe Mount Fuji has any specific restrictions on loading. If it did, I would expect it not to load on desktop either. :thinking: I can’t tell from a glance where the problem would be coming from, but I can propose a few things to try out:

  1. Using Bing Maps in CesiumIonRasterOverlay, does setting the Sub Tile Cache Bytes to zero make a difference?
  2. If the answer to the above is “no”, can you try increasing the Maximum Screen Space Error on the raster overlay? I don’t expect this to solve the problem, but I want to confirm that you are able to zoom in farther before you see the overlay disappear.
  3. To test if it’s specifically a Bing Maps problem, can you try loading Sentinel 2 imagery from Cesium ion as a CesiumIonRasterOverlay?

We’ll use this information to troubleshoot from there. I only have a Quest 2 on hand, so hopefully we can diagnose and resolve the problem on the older device. Thank you in advance!