Stb_image decode failed - model_tiler

First time I’ve come accross this issue, can’t seem to find anything searching arouund. Using the on-premise pipeline.

When tiling a photogrammetry model, recieve the error stb_image decode failed after obj has been converted to temp gltf.

Tried tiling multiple times, not the same image which fails. Any info would be appreciated.


Hello @TomPovey,

We have an internal ticket that might be related to this problem, and I’m hoping to be able to determine if it’s the same issue you’re facing. Would you be able to make your source data available to us (, so that we can try to tile it on our end?


Hi @Matt_Boyd-Surka,

The error popped up again on a different model - I moved the ion engine to a different pc and everything worked fine. Looked like the pc was the issue. Strange since it has never happened before. If you need any details just let me know.


Hi @TomPovey,

Glad to hear you were able to get it working. If you don’t mind sharing any information that could be relevant about the difference between the PCs and/or any sample data, that could help us as we work on this. (I know that’s a pretty broad question—I’ll let you know if we realize there’s anything specific we want to ask.)

Thanks for reporting this.