Unable to select b3dm feature

Hi there,

I am trying to upload a b3dm feature. I have tried using pg2b3dm to generate 3dtiles with tileset.json.
However after uploading to Cesium (i tried Ion asset), it cant be selected. Meaning the mouse click on the model has not pop out.
I am not sure what problem, is it due to geometricError parameter?

The batchTable is valid as I could use b3dm-tile-cs to read it out.
If someone could have faced the same issue and can enlighten a bit?
Greatly appreciated.

I can share the b3dm datasets if required.


Welcome to the community! Can you please tell me a little bit more about your use case? Is there any particular reason why you are not uploading your b3dm feature to Cesium ion and converting your feature to 3D Tiles there (instead of using pg2b3dm)?

Cesium does offer local tiling. Here is some more information about tiling on-premise:

Generally, this is a solution for very specific use-cases. Looking forward to hearing from you!


The very specific reason we couldnt use the tiling is due to the Application Domain Extension (ADE) that we developed for storing CityGML compliant data. Unfortunately Cesium ION could not tile that ADE-specific CityGML. Hence pg2b3dm.

The current problem is, though I am able to tile it, the uploaded b3dm cant be selected and showing its attributes.

Do you require me to share the b3dm data?


Hi @carnegiea, if the asset is still in ion, could you please share the asset ID with us? That would help us begin investigating.

Thanks for that.

The asset ID would be

    url: Cesium.IonResource.fromAssetId(519431)



Ignore the previous reply, the below one is valid

url: Cesium.IonResource.fromAssetId(519435)

Hi @carnegiea, thanks for supplying the b3dm data. I unfortunately haven’t been able to pinpoint the problem based on that, but here is a post that may be useful to you: Programatically select a 3D building

If that doesn’t work, you could send us the original CityGML data to take a look at. I understand it uses a custom ADE and may not be able to be tiled by ion, but examining it may help us understand the problem.

Hi Matt,

Can i know if you able to view the 3D, but wasnt able to select the 3D?
I have to make sure if the b3dm that I shared is actually valid in terms of data structure, which I may need your guide.
But this model was exported from PostGIS, imported by FME, then exported by pg2b3dm.

I think investigating the POSTGIS data better than the CityGML itself?


Hi Matt,

do you think you can help to check this model again if you find anything out of norm? I still couldnt get the default selection working.


Thanks a lot.


Hi Bernad,

Yes, I’m able to view the model, but clicking on the buildings doesn’t have any effect. Sounds like this is what you’re seeing as well.

It’s possible that the pipeline you’re using isn’t connecting the batch table to specific features. I would recommend you take a look at this spec.

This may also be a good question to ask the pg2b3dm team, if you haven’t already. They might be in a better position to help determine the problem in this case.